Thursday, 15 June 2017

Rational Software Architect Designer

Having just installed RSAD version 9.6 on mac OS I tried to open the application from my home screen. However I got an error message pointing me at:

 In there I got the following error message:

!ENTRY org.eclipse.osgi 4 0 2017-06-15 10:18:34.787
!MESSAGE Bundle not found.

!ENTRY 0 0 2017-06-15 10:18:35.138
!MESSAGE Product could not be found.

!ENTRY org.eclipse.osgi 4 0 2017-06-15 10:18:35.335
!MESSAGE Application error
java.lang.RuntimeException: No application id has been found.
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at org.eclipse.equinox.launcher.Main.invokeFramework(
at org.eclipse.equinox.launcher.Main.basicRun(


The work around I would usually follow is to open the application from the command line:

Hoever I already have an eclipse environment that I use for Pure Script Package creation. The above command opens my existing eclipse and not the RSAD eclipse workspace. I also don't want to have to open the application via the command line every time!

Instead the answer lies here:

Thanks to "ericlmk" who says to:
go to File: /Applications/IBM/SoftwareDeliveryPlatform/

Change $ECLIPSE_APP -product &
to $ECLIPSE_APP -product &

Version mixup in the execute script. oops. 

1 comment: